Welcome to Sysnet Board คู่มือ การใช้งานอุปกรณ์ Network. Please log in or sign up.
สมาชิกทั้งหมด
17,669
กระทู้ทั้งหมด
9,931
หัวข้อทั้งหมด
4,628

  • การ Block Facebook และ UnBlock บางเครื่อง ด้วย Router Board
    เริ่มโดย yod
    Read 42,343 times
0 สมาชิก และ 1 ผู้มาเยือน กำลังดูหัวข้อนี้
yod

 

 

การ Block Facebook และ UnBlock บางเครื่อง ด้วย Router Board




เป็นวิธีการ Block Facebook และสามารถไม่ Block สำหรับบาง IP Address ได้ครับ


1. ตรวจสอบ Interface ขา Lan ของ Router Board ก่อนนะครับ จากตัวอย่างของผมชื่อจะเป็น ether5-local-slave หรือถ้าที่ทางผม Config ไว้ให้ส่วนใหญ่จะเป็น bridge1 คือขา 2-5 เชื่อมถึงกัน




2. ตัวอย่าง IP Address ที่เครื่องผมเป็น 192.168.100.251 ซึ่งจะอนุญาติให้ใช้ Facebook ได้ครับ




3. แก้ไข Script ด้านล่างนี้ ตามอักษรสีแดงเลยครับ

/ip firewall address-list
add address=192.168.100.251 comment="" disabled=no list=fbWhitelist
add address=31.13.24.0/21 comment="" disabled=no list=fb
add address=31.13.64.0/18 comment="" disabled=no list=fb
add address=66.220.144.0/20 comment="" disabled=no list=fb
add address=69.63.176.0/20 comment="" disabled=no list=fb
add address=69.171.224.0/19 comment="" disabled=no list=fb
add address=74.119.76.0/22 comment="" disabled=no list=fb
add address=103.4.96.0/22 comment="" disabled=no list=fb
add address=173.252.64.0/18 comment="" disabled=no list=fb
add address=204.15.20.0/22 comment="" disabled=no list=fb

/ip firewall filter
add action=drop chain=forward comment="facebook drop" disabled=no dst-address-list=fb dst-port=443 in-interface=ether5-local-slave protocol=tcp src-address-list=!fbWhitelist


4. แปะ Script ที่แก้ไขแล้ว New Terminal โดย Click Mouse ขวาเลือก Paste แล้วเคาะ enter อีก 1 ครั้ง




5. เข้า Menu IP --> Firewall --> Address List



กด [ + ] คือเพิ่มรายการ
Name: fb คือ Server ของ Facebook ครับ ยังไม่ต้องสนใจ ไว้ทางนั้นเขาเปลี่ยนหรือเพิ่ม Server ค่อยหาแล้วเอามาเพิ่มในนี้ครับ
Name: fbWhitelist คือหมายเลข IP Address ที่ต้องการให้ใช้ Facebook ได้ครับ


6. เข้า Menu IP --> Firewall --> Filter Rules
ลากรายการ Facebook Drop ขึ้นมาแถวบนๆครับ




7. ลองทดสอบเข้า Facebook ดูครับ Firewall จะทำการจับ Package ที่วิ่งไปหา Server ของ Facebook ได้



ผมลองทดสอบแล้ว ณ.วันที่ 5/11/2012 block ได้นะครับ (เผื่ออนาคต block ไม่ได้ค่อยหาทางแก้กันใหม่  ;D)





และจะมีอีกวิธีนึงครับ ใช้ L7 Filter ของตัว Mikrotik เอง โดยใช้ expression ดังนี้ครับ เดี๋ยวว่างๆจะมาลงวิธีให้อีกครั้งโดยละเอียดครับ  ;)

^.+(facebook.com).*$



เรียบร้อยครับ   ;D ;D



รบกวนสอบถามเพิ่มครับ ถ้าผมจะ Block facebook  youtube ทั้งวัน  ยกเว้น  เที่ยงกับหลัง 17.00 น  สามารถทำได้ไหมครับ

yod


ได้ครับ มีหัวข้อการ enable/disable ตามช่วงเวลา อยู่ใน webboard อยู่แล้ว ลองหาดูครับ