Knowledge Zone:: By Sysnet การ config และ ใช้งานอุปกรณ์ Network

Mikrotik การ Lock IP เข้ากับ MAC Address ถ้าไม่ตรงกันจะเข้า Internet ไม่ได้

Discussion started on อุปกรณ์ Mikrotik Router

Mikrotik การ Lock IP เข้ากับ MAC Address ถ้าไม่ตรงกันจะเข้า Internet ไม่ได้



ตั้งหัวข้อเองงงเอง  ;D


ประมาณว่ากำหนดอุปกรณ์ Mikrotik ให้ Mac Address ของเครื่อง A ต้องเป็นหมายเลข IP: a.a.a.a ตามที่เรากำหนดครับ ถ้าเขา Fix เป็น IP อื่นๆ จะเข้าใช้งานในวง Network ไม่ได้ หรือ Mac Address เครื่องอื่นมา Fix เป็น IP: a.a.a.a ก็ไม่สามารถใช้งานได้เช่นกัน


ขั้นแรก Click [Safe Mode] ที่มุมซ้ายบนของ Winbox ถ้าผิดพลาดอะไร ปิด/เปิด RouterBoard ใหม่จะเป็นค่าเดิมก่อน Click และก็ Add เครื่องที่ใช้งานก่อนนะครับ



1. จากตัวอย่างค่า Mac Address ที่ Card Lan (ค่า MAC Address ของ Card Lan กับ Wireless จะคนละค่ากันนะครับ ถ้าต่อด้วย Wireless ก็ต้องใช้ค่า MAC Address ของ Card Wireless ในเครื่อง) ของเครื่องผม ต้องเป็น IP: 192.168.2.60 ถ้าเข้าดูรายละเอียดตามรูป สามารถกดปุ่ม Ctrl + C แล้วไปแปะที่ Notepad ได้เลยครับ




แก้ไข Script ให้ Mac Address ตรงกับ IP Address ที่ต้องการ (ตัวแดง)

/ip firewall filter add chain=forward src-address=192.168.2.60 src-mac-address=!84:8F:69:CB:95:DB action=drop disabled=no
/ip firewall filter add chain=forward src-address=!192.168.2.60 src-mac-address=84:8F:69:CB:95:DB action=drop disabled=no


2. เมื่อแก้ไขแล้วให้แปะที่ New Terminal (Click Mouse ขวา) ใน Mikrotik Winbox




3. จะมีรายการขึ้นมาที่ Menu IP --> Firewall --> Filter




4. เครื่องผมตอนนี้ IP เป็น 192.168.1.190 ลองเข้า Internet จะเข้าไม่ได้ครับ




5. ทีนี้ก็ Fix IP เป็น 192.168.2.60 เข้าใช้งาน Internet ได้ปกติ





พอดีมีลูกค้าท่านนึงถามมาครับ ต้องการจัดการ Bandwidth ของเครื่อง Computer ด้วยครับ  ;D

ให้เข้า Menu Queue แล้ว Add ตามรูปได้เลย





เรียบร้อยครับ  ;D ;D


#1 - วันที่ 11 พฤศจิกายน 2012, 17:36:24

 :-\ ลองแล้วครับสคริปส์ตัวนี้ แต่มันออกเน็ตไม่ได้คาับ  ไม่รู้ว่าผิดพลาดตรงไหน ของผม OS 5.12
#2 - วันที่ 18 ธันวาคม 2012, 13:03:31


Mac address ของ Card Wireless กับ Card Lan ในเครื่อง Computer จะไม่ตรงกันนะครับ
#3 - วันที่ 18 ธันวาคม 2012, 13:37:39

ใช้ครับ ลองแล้วไม่ได้ครับ  :-\
#4 - วันที่ 18 ธันวาคม 2012, 15:10:09

ip/dhcp server/leases make static ip  แล้ว ก็ไม่ได้
#5 - วันที่ 18 ธันวาคม 2012, 15:16:27

มี packets วิ่งเข้าออกแต่ออกเน็ตไม่ได้
#6 - วันที่ 18 ธันวาคม 2012, 15:33:40

ถ้ามี Packets ออกใน filter rules แสดงว่าเข้าเงื่อนไข จะออก internet ไม่ได้ครับ


ตัวอย่างที่ผมทดสอบครับ ตั้ง ip/mac ตรง ออก internet ได้

จากนั้นเปลี่ยน ip ก็ออก internet ไม่ได้ และมี packets ขึ้นใน filter rules ที่สร้างครับ


#7 - วันที่ 18 ธันวาคม 2012, 15:48:44

อ้อ..ลากให้ filter rules 2 ตัว นี้อยู่บนๆนะครับ
#8 - วันที่ 18 ธันวาคม 2012, 15:57:44

/ip firewall filter add chain=forward src-address=192.168.2.60 src-mac-address=!84:8F:69:CB:95:DB action=drop disabled=no
/ip firewall filter add chain=forward src-address=!192.168.2.60 src-mac-address=84:8F:69:CB:95:DB action=drop disabled=no

จากข้อความ "/ip firewall filter add chain=forward"


แต่ทำไม ภาพด้านล่างข้อ 3 ถึง ช่อง chain โชว์เป็น Input ครับ
#9 - วันที่ 24 สิงหาคม 2013, 23:12:35

ทำไมบางเว็ป เข้าได้อ่าครับ เช่น youtube mazzda อะครับ
#10 - วันที่ 28 กันยายน 2013, 09:23:46

เรียน คุณยอด

ลอง script นี้แล้วครับ google กับ facebook  เข้าไม่ได้ครับ แต่ youtube กับเวป็ mazda เข้าได้สบายเลย ทั้งที่ ip กะ mac ไม่ตรงกันอ่าครับ ต้องแก้ยังยังครับ ถ้า mac กับ ip ไม่ตรงกัน จะไม่ให้ออกได้เลยแม้แต่เว็ปเดียว
รบกวนด้วยครับ
#11 - วันที่ 30 กันยายน 2013, 08:05:15

ขอบคุณครับ
#12 - วันที่ 8 ตุลาคม 2013, 23:36:05

ตามมาดูกระทู้นี้ ปรากฎว่าเงียบสนิท ไปต่อไม่ถูกเลยครับ  ???
#13 - วันที่ 26 เมษายน 2014, 23:38:29

สมาชิก:

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้


* Share Topic

Share via facebook

* Similar Topics

xx
pico station m2hp mode ap wds แล้วตั้งล็อค mac address ไม่ได้ ต้องทำไงครับ

เริ่มโดย sasuke เมื่อ อุปกรณ์ UBiQUiTi (ยูบิ-คิวตี้)

2 ตอบ
5531 อ่าน
กระทู้ล่าสุด วันที่ 1 สิงหาคม 2014, 22:04:21
โดย pongeiei
xx
การ Block Mac-Address บางเครื่องไม่ให้เข้าใช้งาน Internet

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
9263 อ่าน
กระทู้ล่าสุด วันที่ 7 มิถุนายน 2018, 11:39:15
โดย เด่น บางพลี
xx
รบกวนช่วยหน่อยครับ ออก internet ได้ แต่เข้า iBSG กับ CCTV ไม่ได้

เริ่มโดย Mikey Niranai Tuntamee เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
1054 อ่าน
กระทู้ล่าสุด วันที่ 20 กันยายน 2018, 12:38:41
โดย yod
sad
เปลี่ยนมาใช้เน็ตของ TT&T แล้วเสียบ AP Pico StationM2 เข้า Internet ไม่ได้

เริ่มโดย itparty123 เมื่อ อุปกรณ์ UBiQUiTi (ยูบิ-คิวตี้)

2 ตอบ
4247 อ่าน
กระทู้ล่าสุด วันที่ 18 สิงหาคม 2015, 16:06:54
โดย itparty123
moved
ย้ายแล้ว: เปลี่ยนมาใช้เน็ตของ TT&T แล้วเสียบ AP Pico StationM2 เข้า Internet ไม่ได้

เริ่มโดย yod เมื่อ สอบถามข้อมูลทั่วๆไป ข่าวสารจากร้าน Sysnet Center

0 ตอบ
2354 อ่าน
กระทู้ล่าสุด วันที่ 16 สิงหาคม 2015, 16:32:18
โดย yod