Knowledge Zone:: By Sysnet การ config และ ใช้งานอุปกรณ์ Network

ทำ VPN Site To Site แบบ PPTP ผ่าน Dynamic DNS

Discussion started on อุปกรณ์ Mikrotik Router

ทำ VPN Site To Site แบบ PPTP ผ่าน Dynamic DNS




ทำตามขั้นตอน พอคล่องแล้วค่อยแก้ไขครับ แต่ทางผมขอแจ้งไว้ก่อนนะครับ เนื่องจากการทำ VPN ปัญหาการเชื่อมต่อไม่ได้ จะมีหลายสาเหตุ ทางผมขออนุญาติไม่รับ Support โดยตรงนะครับ ถ้าติดปัญหาให้ Post ที่ หัวข้อนี้ได้เลยครับ หรือถ้า Config แบบง่ายๆ (ง่ายสุดๆ) ให้เลือกใช้เป็นอุปกรณ์ VPN Firewall Router โดยตรงจะดีกว่าครับ



จากรูปจะเป็นตัวอย่างการทำ VPN Site To Site แบบ PPTP เชื่อมต่อผ่าน Dynamic DNS ค่า IP ต้องคนละวงกันนะครับ




โดยฝั่ง Office จะเป็น IP: 192.168.1.1 (วง 192.168.1.0) ทำ Dynamic DNS เป็น sysnethost.dyndns.org (ตัวอย่างสมมุตินะครับ)
และฝั่ง Site จะเป็น 102.168.2.1 (วง 192.168.2.0) ทำ Dynamic DNS เป็น sysnetsite.dyndns.org (ตัวอย่างสมมุตินะครับ)




โดยปกติทำการติดตั้ง Dynamic DNS เรียบร้อยแล้ว เราจะสามารถ Remote ไป Config อีกฝั่งหนึ่งได้เลยครับ ในตัวอย่างผมอยู่ฝั่ง Office แล้ว Remote ไป Config ที่ฝั่ง Site ด้วยครับ หรือให้ทีมงานอยู่อีกฝั่งนึง แล้วแจ้งหมายเลข Address ของ pppoe-out ก็สามารถเข้าผ่าน winbox ได้เช่นกันครับ


Config อุปกรณ์ RouterBoard ให้ออก Internet ให้เรียบร้อยครับ
การ Config อุปกรณ์ Mikrotik RouterBoard เบื้องต้น
การ Config Dynamic DNS ด้วย Service dyndns.org


[Config ฝั่ง Office]

1. เข้า Menu PPP --> Profiles --> Click [ + ]
ตั้งชื่อ Profile: profile1
Local Address: 192.168.10.1
Remote Address: 192.168.10.2



Click [Apply]


เข้า Tab Protocols เลือก Use Encryption เป็น yes



Click [OK]


2. เข้า Tab Secrets --> Click [ + ]
กำหนด Name: ppp1
Password: ppp1
Profile: profile1



Click [OK]


Tip

ปกติเวลา Connect PPtP เข้ามา ทาง Mikrotik จะสร้าง Route ไว้ให้อัตโนมัติ แนะนำให้ Fix Route ที่นี้จะดีกว่าครับ



3. เข้า Tab Interface --> Click [PPTP Server]
Click เลือก Enable
Default Profile: default



Click [OK]


4. Tab Interface --> Click [ + ] เลือก PPTP Server
กำหนดตามรูปได้เลยครับ



จากนั้น Click [OK]



[Config ฝั่ง Site]

1. เข้า Menu PPP --> Tab Interface --> Click เลือก PPTP Client
ที่ Tab Dial Out
Connect To: ใส่ Dynamic DNS ของทางฝั่ง Office
User: ppp1
Password: ppp1
เมื่อ Click [OK] RouterBoard จะทำการ Resolve IP ให้อัตโนมัติที่ช่อง Connect To





[การสร้าง Route เพื่อให้สามารถเชื่อมไปยัง Lan ของ Router ได้]


[ฝั่ง Office]

เข้า Menu --> IP --> Route --> Click [ + ]
Dst Address: 192.168.2.0/24 (วง Network ฝั่ง Site)
Gateway: pptp-in1



เมื่อ Click [Apply] ถ้าเชื่อมต่อได้จะขึ้น reachable


[ฝั่ง Site]

เข้า Menu --> IP --> Route --> Click [ + ]
Dst Address: 192.168.1.0/24 (วง Network ฝั่ง Office)
Gateway: pptp-out1



เมื่อ Click [Apply] ถ้าเชื่อมต่อได้จะขึ้น reachable



ทดสอบ

ถ้า Connect เรียบร้อยจะมี Status R นำหน้าครับ ทั้งฝั่ง Site และ Office






ลองเข้า New Terminal แล้ว Ping ไปยัง Router อีกฝั่งครับ









ปัญหา

เนื่องจาก IP ที่ช่อง Connect To ตอนที่สร้าง ppptp-client ที่ฝั่ง site มันจะทำการ Resolve IP จาก dynamic dns ณ.เวลาที่ click [Apply] ปัญหาคือ มันจะจำค่านี้ไปตลอด ถ้า RouterBoard ฝั่ง Office ได้รับ IP Address ค่าใหม่จาก ISP และ Update ไปยัง Server Dynamic DNS แล้ว ค่า Connect To ที่ฝั่ง site มันดันไม่เปลี่ยนค่าตามไปด้วยครับ

ตอนทดสอบเพื่อทำคู่มือก็ใช้งานได้ปกติ แต่พอใช้งานจริงจากที่บ้านและที่ร้าน เลยเจอปัญหาครับ งมอยู่นานเลย


ทางแก้

ผมเลยสร้าง Script ให้ไปอ่านค่า IP จาก Dynamic DNS แล้วเข้ามา Update ใน Connect To ของ PPTP-Client ให้อัตโนมัติ

Script แบบ 1

โค๊ด: [Select]
#Update field Connect To in PPTP-Client
#Create by Thanavich Sriarun
#https://www.sysnetcenter.com

:global currentIP [:resolve sysnetxxxx.dyndns.org]
:global previousIP [/interface pptp-client get 0 connect-to]
:delay 1

:log info "Curent IP: $currentIP and $previousIP"

:if ($currentIP != $previousIP) do={
:set previousIP $currentIP
/interface pptp-client set 0 connect-to=$currentIP
:log info ("Update Current IP $currentIP")
} else={
   :log info ("No Update Current IP")
}

แก้ไขตรง sysnetxxxx.dyndns.org ให้เป็นค่า Dynamic DNS ของทางฝั่ง Office ครับ จากนั้นก็เข้าไปใส่ใน Sytem --> Script

สร้าง Script ชื่อ getResolveDNS แล้วก็ Copy Code ที่แก้แล้วลงไป




จากนั้นก็สร้าง Schedule ให้ทำการ Run Script ทุกๆ 1 นาที


โค๊ด: [Select]
/system scheduler add name=resolveIP interval=00:01 on-event="/system script run getResolveDNS\r\n"

หรือจะใช้ Script แบบง่ายๆก็ได้ครับ แต่ผมไม่แน่ใจว่าการ set ค่า ip ให้กับ pptp-client ตลอดจะมีปัญหาอะไรหรือเปล่าครับ


โค๊ด: [Select]
:global currentIP [:resolve sysnetxxxx.dyndns.org]
:delay 1
/interface pptp-client set 0 connect-to=$currentIP


เรียบร้อยครับ ทำแบบเร่งด่วน  ;D ;D

ส่วนการทำแบบ Dial-Up มาจากอุปกรณ์ Smart Phone, Windows เดี๋ยวค้างไว้ก่อนครับ หรือถ้าจะลอง แต่ทำแค่ฝั่ง Office จากนั้นก็สร้าง Dial เชื่อมเข้ามาได้เลย
#1 - วันที่ 4 ธันวาคม 2012, 11:49:45

ตั้งชื่อ Profile: profile1
Local Address: 192.168.10.1
Remote Address: 192.168.10.2


ค่า 192.168.10.1 เอามาจาไหนนะครับ เรากำหนดเองใช่ไหมครับ
#2 - วันที่ 14 ธันวาคม 2012, 03:32:18


เป็น ip ไว้เชื่อมถึงกันครับ ตั้งตามนี้ได้เลยครับ
#3 - วันที่ 14 ธันวาคม 2012, 05:06:28

เรียน คุณ ยอด อยากทราบว่า ถ้าเราทำ VPN หลาย Site เช่น 4 Site เราต้อง config ยังไงครับ ตอนนี้ Site To Site ได้แล้วครับ
พอดีทำไม่ค่อยเป็นครับ รบกวนด้วยนะครับ
#4 - วันที่ 2 กุมภาพันธ์ 2013, 08:10:54

เรียน คุณยอด
 
ทำไม vpn แล้วรีโมต 3389 ไม่ได้อะครับ ping เจอ แต่ remtoe ไม่ได้อ่าครับ
#5 - วันที่ 22 กันยายน 2013, 21:47:12



ติด firewall หรือเปล่าครับ ถ้าข้าม subnet ต้อง disable firewall ด้วยนะครับ
#6 - วันที่ 23 กันยายน 2013, 15:46:52


3 site ที่เหลือต่อเข้า site ต้นทางได้เลยครับ และ site ต้นทางก็เพิ่ม site ปลายทางเข้าไป

สรุป

site ที่ต้นทางมี vpn 3 tunnel แต่ละ tunnel ชี้ไปที่ vpn ปลายทาง
ที่ site ปลายทางมี vpn อย่างละ tunnel ชี้ไปที่ vpn ต้นทาง
#7 - วันที่ 23 กันยายน 2013, 15:48:38

เรียนคุณยอด

ดังภาพครับ หาก vpn  ระหว่าง mikrotik กับ windows  สามารถ remote 3389 ได้ครับ
แต่ถ้าเชื่อมระหว่าง mikrotik กับmikrotik   จะไม่สามารถ  remote 3389 ได้ครับ  ผมเซต port 1723 และ grc แล้วก็ไม่ได้   ผม ปล่อยวง  lan ผ่าน nat ทั้ง วงก็ไม่ได้ครับ งง มากมาย
ping เจอปกติ แชร์ไฟล์งาน ก็อบปี้ ได้ตามปกติ เหลือแค่ remote อย่างเดียวครับ  
ขอบคุณครับ
#8 - วันที่ 23 กันยายน 2013, 16:14:56


ถ้าเป็นการใช้ software dial up เข้าไปจะเป็นเหมือนวง network เดียวกันครับ

แต่ถ้าทำลักษณะ site to site มันจะเป็นคนละวงกัน โดยค่า default firewall ของ windows มันจะไม่ยอม ต้องปิดหรือ disable ก่อนครับ ถ้า windows xp จะมีอยู่ในหน้า firewall advance ให้ remote หรือ share file ต่าง subnet ได้ แต่ windows 7 ยังหาไม่เจอเลยครับ
#9 - วันที่ 24 กันยายน 2013, 07:34:10

firewall ของ windows ปิดอยู่แล้วครับ ทั้ง win7 และ xp แต่ก็ยังขึ้น เหมือนเดิมอะครับ
#10 - วันที่ 24 กันยายน 2013, 07:49:09

#Update field Connect To in PPTP-Client
#Create by Thanavich Sriarun
#https://www.sysnetcenter.com

:global currentIP [:resolve sysnetxxxx.dyndns.org]
:global previousIP [/interface pptp-client get 0 connect-to]
:delay 1

:log info "Curent IP: $currentIP and $previousIP"

:if ($currentIP != $previousIP) do={
:set previousIP $currentIP
/interface pptp-client set 0 connect-to=$currentIP
:log info ("Update Current IP $currentIP")
} else={
   :log info ("No Update Current IP")
}

เรียนคุณยอด script นี้ ใส่ฝั่ง client แล้วถ้า server มีสองที่ละครับ เช่น server1 = ii.ddns.org  server2= rr@ddns.org แล้วเราเป็น client  จะทำยังไงให้เช็ค ip ทั้งสองที่แล้ว อัพเดท ip ที่ pptp1 และ pptp2 ครับ
รบกวนด้วยครับ
#11 - วันที่ 13 กันยายน 2014, 10:12:02

ทำได้แล้วครับ
#12 - วันที่ 13 กันยายน 2014, 15:53:40

สอบถามครับ พอดีผมมี Site 3 Site ตอนนี้ของเดิม เขาทำไว้มี Site 2 เชื่อมต่อกับ Office ได้แล้ว เหลือ Site ที่ 3 ผมได้ทำการเพิ่ม  PPTP Client และเพิ่ม Routes ที่ Site 3 โดย Routes ไปที่ไอพี Office ส่วนที่ Office ก็เพิ่ม Routes ไอพีปลายทางเข้าไปครับ ผลปรากฎว่ามันไม่สามารถ Connect หากันได้ครับ ping ก็ไม่เจอกันครับ มีแนวทางการแก้ปัญหายังไงได้บ้างครับแบบนี้ ขอบคุณครับ พี่ยอด
#13 - วันที่ 4 ตุลาคม 2018, 14:47:55

สมาชิก:

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้


* Share Topic

Share via facebook

* Similar Topics

xx
ทำ Load Balance 2 Wan แบบ PPOE และทำ PPTP site to site กับ Draytek

เริ่มโดย mythory เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
848 อ่าน
กระทู้ล่าสุด วันที่ 10 มกราคม 2019, 11:25:11
โดย mythory
xx
การ Config Mikrotik เพื่อทำระบบ VPN แบบ PPTP ในรูปแบบ Client To Site

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

5 ตอบ
18736 อ่าน
กระทู้ล่าสุด วันที่ 18 กันยายน 2019, 16:47:11
โดย wittayapsnet
xx
เดิมใช้ Fortigate IPSec VPN Site to Site ระหว่างสาขา แต่อยากจะใช้ Mikrotik ...

เริ่มโดย chaichai เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
3141 อ่าน
กระทู้ล่าสุด วันที่ 21 มิถุนายน 2017, 20:59:26
โดย chaichai
xx
การทำ VPN แบบ Site To Site ด้วย QNO Load balance VPN Router

เริ่มโดย yod เมื่อ อุปกรณ์ QNO (คิวโน่)

0 ตอบ
16261 อ่าน
กระทู้ล่าสุด วันที่ 29 มีนาคม 2012, 15:24:52
โดย yod
xx
สอบถามการ Config cisco RV042 ทำ site to site (Fix ip )

เริ่มโดย tooktaa เมื่อ อุปกรณ์ Cisco, Linksys By Cisco

2 ตอบ
5210 อ่าน
กระทู้ล่าสุด วันที่ 11 สิงหาคม 2016, 14:59:59
โดย Billysnoop