Knowledge Zone By Sysnet คู่มือ และ การใช้งานอุปกรณ์ Network

การทำ Loadbalance Internet Static IP 2 เส้น แบบ PCC

Discussion started on อุปกรณ์ Mikrotik Router

การทำ Loadbalance Internet Static IP 2 เส้น แบบ PCC



การทำ loadbalance แบบนี้ ข้อดีคือจะจัดการตาม session เลยครับ เพราะฉะนั้นจะไม่มีปัญหาเรื่องการเข้า web พวก ssl แต่ค่อนข้างจะกิน cpu นะครับ ไม่แนะนำให้ใช้กับรุ่น Mikrotik RB-750 แต่ถ้าใช้ร่วมกับระบบ Hotspot Server ควรเป็นรุ่น RB-450G ขึ้นไปครับ

ตัวอย่างจะเป็นการต่อ Internet 2 คู่สาย โดยอาจจะใช้ร่วมกับ Cable Modem, Fiberoptic หรือ Interent ที่รับมาจาก Wireless เช่น TOT Winet




Port Ether1 ของ Mikrotik เข้ากับ Router#1 เป็น IP 192.168.2.1 และ Port Ether2 เข้ากับ Router#2 เป็น IP 192.168.3.1 กำหนด IP ที่ตัว Mikrotik ที่ Port Ether1=192.168.2.2 และ Port Ether2=192.168.3.2 ให้ Port Ether3-5 เป็น Bridge (สะพาน) เชื่อมถึงกัน IP เป็น 192.168.1.1

IP Address ของฝั่ง Internet กับฝั่ง Lan ของ Mikrotik ห้ามอยูในวง Network เดียวกันนะครับ


เนื่องจากการ Config อุปกรณ์ Mikrotik จะสามารถทำได้หลายรูปแบบแต่ให้ผลลัพท์ที่เหมือนกัน จะขออ้างอิงการ Config ต่อเนื่องจากหัวข้อ

การ Config อุปกรณ์ Mikrotik RouterBoard เบื้องต้น #1
การ Config อุปกรณ์ Mikrotik RouterBoard เบื้องต้น #2


หรือจากที่ผม Config ส่งไปให้ครับ ในกรณีที่ Config อะไรไปเยอะแล้ว แนะนำให้ Backup ไว้ และRestore ค่าที่ผม Backup ไว้ก่อนครับ  :D


1. Login เข้า Winbox เข้า Menu PPP ให้ Disable pppoe-out1




2.  เข้า Menu Bridge --> Ports ให้ลบ ether2 ออกจากสมาชิกใน Bridge1 จะเหลือเพียง ether3,4,5 ในกรณีใช้ 3Wan ก็ลบ ether3 ออกด้วยครับ




3. เข้า Menu IP --> Address สร้าง Network ขึ้นมาสำหรับ Port ether2
Address: 192.168.2.2/24
Network: 192.168.2.0
Interface: ether1



Click [OK]

เสร็จแล้วสร้าง Address สำหรับ Port ether3
Address: 192.168.3.2/24
Network: 192.168.3.0
Interface: ether2



Click [OK]


4. Copy script ด้านล่าง เลือกเอาอย่างใดอย่างนึงนะครับ

#ไม่ได้ทำ Hotspot Server

โค๊ด: [Select]
/ip firewall mangle
add action=accept chain=prerouting disabled=no in-interface=eth1
add action=accept chain=prerouting disabled=no in-interface=eth2

add action=mark-connection chain=prerouting disabled=no dst-address-type=!local \
new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0 src-address=192.168.1.0/24

add action=mark-connection chain=prerouting disabled=no dst-address-type=!local \
new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1 src-address=192.168.1.0/24


add action=mark-routing chain=prerouting connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes src-address=192.168.1.0/24
add action=mark-routing chain=prerouting connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes src-address=192.168.1.0/24

/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=eth1 src-address=192.168.1.0/24
add action=masquerade chain=srcnat disabled=no out-interface=eth2 src-address=192.168.1.0/24

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_wan1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_wan2 scope=30 target-scope=10

add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=30 target-scope=10


#ใช้ร่วมกับ Hotspot Server

โค๊ด: [Select]
/ip firewall mangle
add action=accept chain=prerouting disabled=no in-interface=eth1
add action=accept chain=prerouting disabled=no in-interface=eth2

add action=mark-connection chain=prerouting disabled=no dst-address-type=!local hotspot=auth \
new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0 src-address=192.168.1.0/24

add action=mark-connection chain=prerouting disabled=no dst-address-type=!local hotspot=auth \
new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1 src-address=192.168.1.0/24


add action=mark-routing chain=prerouting connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes src-address=192.168.1.0/24
add action=mark-routing chain=prerouting connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes src-address=192.168.1.0/24

/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=eth1 src-address=192.168.1.0/24
add action=masquerade chain=srcnat disabled=no out-interface=eth2 src-address=192.168.1.0/24

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_wan1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_wan2 scope=30 target-scope=10

add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=30 target-scope=10


Copy แล้ว Click ขวาเลือก Paste ที่ New Terminal



เคาะ Enter 1 ครั้ง


5. เข้า Menu IP --> Firewall --> NAT
Disable รายการตามรูป จะเหลือแค่ 2 รายการครับ รายการที่ Disable จะเป็น NAT mทาง Hotspot Server สร้างเอาไว้อัตโนมัติ




6. ตรวจสอบรายการที่ Menu IP --> Firewall --> Mangle





ทดสอบ

ปล่อย Internet เส้นละ 3Mbps เมื่อ Download Bittorrent จะได้ 6Mbps เต็มๆครับ




ดึงสาย Internet ออกทีละเส้น ในกรณีที่ Internet เส้นใดเส้นนึงมีปัญหา จะต้อง Download ได้ปกติ






เรียบร้อยครับ
#1 - วันที่ 15 มีนาคม 2013, 17:47:14

รบกวนถามหน่อยครับว่า
ถ้าไม่ต้องการทำ Loadbalance Internet Static IP 2 เส้น
แต่ต้องการทำแค่ static wan ip 1 เส้นจะต้องทำยังไงครับ
ขอบคุณครับ
#2 - วันที่ 11 สิงหาคม 2013, 18:02:07

เวลาเล่นเกม online จะมีปัญหาไหมครับ เรื่องการสลับ wan
#3 - วันที่ 26 ตุลาคม 2013, 17:11:44


ยังไม่เคยลองเลยครับ ถ้ามีปัญหากับพวกเกมส์ Online หรือพวก Internet Banking ให้ใช้เป็นแบบ NTH จะดีกว่าครับ
#4 - วันที่ 26 ตุลาคม 2013, 17:13:55


ยังไม่เคยลองเลยครับ ถ้ามีปัญหากับพวกเกมส์ Online หรือพวก Internet Banking ให้ใช้เป็นแบบ NTH จะดีกว่าครับ
[/quote]แล้วแบบ NTH มีที่ไม่ต้องทำ modem เป็น bridge ไหมครับ พอดีใช้ร่วมกับ TOT Winet ด้วย มันไม่สามารถทำให้เป็น bridge ได้
ขอบคุณครับ
#5 - วันที่ 26 ตุลาคม 2013, 18:30:45

พอทำได้ไหมครับ
#6 - วันที่ 28 ตุลาคม 2013, 20:19:59

ลองดูนะครับ ขา 1 PPPoE Client ส่วนขา 2 เป็น Static ครับ

/ ip firewall mangle
add chain=input in-interface=pppoe-out1 action=mark-connection new-connection-mark=wan1_conn
add chain=input in-interface=ether2 action=mark-connection new-connection-mark=wan2_conn

add chain=output connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1
add chain=output connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2

add chain=prerouting dst-address-type=!local hotspot=auth in-interface=bridge1 per-connection-classifier=both-addresses-and-ports:2/0 \
action=mark-connection new-connection-mark=wan1_conn passthrough=yes
add chain=prerouting dst-address-type=!local hotspot=auth in-interface=bridge1 per-connection-classifier=both-addresses-and-ports:2/1 \
action=mark-connection new-connection-mark=wan2_conn passthrough=yes

add chain=prerouting connection-mark=wan1_conn in-interface=bridge1 action=mark-routing new-routing-mark=to_wan1
add chain=prerouting connection-mark=wan2_conn in-interface=bridge1 action=mark-routing new-routing-mark=to_wan2

/ ip route
add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_wan1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_wan2 check-gateway=ping

/ ip firewall nat
add chain=srcnat out-interface=pppoe-out1 action=masquerade
add chain=srcnat src-address=192.168.2.0/24 action=masquerade
#7 - วันที่ 30 ตุลาคม 2013, 16:03:11

ต้องการทำ Load balance Internet Static IP 3 เส้น รุ่น RB-450G ใช้ร่วมกับ Hotspot

- 3 WAN => Eth1,Eth2,Eth3
- 2 LAN => Eth4,Eth5

จะทำได้หรือเปล่า ถ้าทำได้ขอขั้นตอนการทำด้วยครับ
#8 - วันที่ 13 ธันวาคม 2013, 08:31:43

ทำไม Loadbalance ผมใช้สองเส้นแต่เข้าไปดูมันใช้เส้นเดียวตลอด ไม่เห็นมันโหลดพร้อมกัน แต่ถ้าดึงสายหนึ่งออกมันถึงจะใช้อีกสายหนึ่ง
#9 - วันที่ 22 กรกฎาคม 2014, 17:16:02


ลองโหลดบิตที่มีคนปล่อยเยอะๆครับ
#10 - วันที่ 22 กรกฎาคม 2014, 17:28:05

ลองโหลดแล้วคับ..วิ่งอยู่แต่เส้นเดียว 1.5 M ถ้าดึงสายออกถึงจะไปใช้อีกสายหนึ่งให้ แต่ถ้าเน็ตหลุดแบบไม่ถึงสายออก ไม่ยอมสลับให้เลย.
#11 - วันที่ 22 กรกฎาคม 2014, 22:55:51

การทำ Loadbalance ลักษณะนี้ ถ้าเน็ต 2 เส้นความเร็วไม่เท่ากัน จะมีปัญหาอะไรหรือไม่ และความเร็วเน็ตของ 2 เส้นทั้ง Up และ Down จะรวมกันหรือไม่ครับ
#12 - วันที่ 29 กันยายน 2014, 11:14:56


ค่า Internet เท่าไหร่ครับ เดี๋ยวเขียน script ให้ครับ
#13 - วันที่ 29 กันยายน 2014, 15:17:35


ค่า Internet เท่าไหร่ครับ เดี๋ยวเขียน script ให้ครับ
[/quote]

  เส้น Wan 1 = 50M / 10M
  เส้น Wan 2 = 20M / 2M
#14 - วันที่ 29 กันยายน 2014, 16:12:58


ค่า Internet เท่าไหร่ครับ เดี๋ยวเขียน script ให้ครับ
[/quote]

  เส้น Wan 1 = 50M / 10M
  เส้น Wan 2 = 20M / 2M
[/quote]

ลองดูนะครับ มันคำนวนได้ไม่เป๊ะๆครับ ส่วนขา up ไม่มีผลเท่าไหร่ครับ

/ ip firewall mangle
add chain=input in-interface=pppoe-out1 action=mark-connection new-connection-mark=wan1_conn
add chain=input in-interface=pppoe-out2 action=mark-connection new-connection-mark=wan2_conn

add chain=output connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1
add chain=output connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no dst-address-type=!local hotspot=auth src-address=192.168.1.0/24 new-connection-mark=\
    wan1_conn passthrough=yes per-connection-classifier=both-addresses:3/0

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no dst-address-type=!local hotspot=auth src-address=192.168.1.0/24 new-connection-mark=\
    wan1_conn passthrough=yes per-connection-classifier=both-addresses:3/1

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no dst-address-type=!local hotspot=auth src-address=192.168.1.0/24 new-connection-mark=\
    wan2_conn passthrough=yes per-connection-classifier=both-addresses:3/2

add chain=prerouting connection-mark=wan1_conn in-interface=bridge1 action=mark-routing new-routing-mark=to_wan1
add chain=prerouting connection-mark=wan2_conn in-interface=bridge1 action=mark-routing new-routing-mark=to_wan2

/ ip route
add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_wan1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_wan2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=pppoe-out1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=pppoe-out2 distance=2 check-gateway=ping

/ ip firewall nat
add chain=srcnat out-interface=pppoe-out1 action=masquerade
add chain=srcnat out-interface=pppoe-out2 action=masquerade
#15 - วันที่ 29 กันยายน 2014, 16:26:26


ค่า Internet เท่าไหร่ครับ เดี๋ยวเขียน script ให้ครับ
[/quote]

  เส้น Wan 1 = 50M / 10M
  เส้น Wan 2 = 20M / 2M
[/quote]

ลองดูนะครับ มันคำนวนได้ไม่เป๊ะๆครับ ส่วนขา up ไม่มีผลเท่าไหร่ครับ

/ ip firewall mangle
add chain=input in-interface=pppoe-out1 action=mark-connection new-connection-mark=wan1_conn
add chain=input in-interface=pppoe-out2 action=mark-connection new-connection-mark=wan2_conn

add chain=output connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1
add chain=output connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no dst-address-type=!local hotspot=auth src-address=192.168.1.0/24 new-connection-mark=\
    wan1_conn passthrough=yes per-connection-classifier=both-addresses:3/0

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no dst-address-type=!local hotspot=auth src-address=192.168.1.0/24 new-connection-mark=\
    wan1_conn passthrough=yes per-connection-classifier=both-addresses:3/1

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no dst-address-type=!local hotspot=auth src-address=192.168.1.0/24 new-connection-mark=\
    wan2_conn passthrough=yes per-connection-classifier=both-addresses:3/2

add chain=prerouting connection-mark=wan1_conn in-interface=bridge1 action=mark-routing new-routing-mark=to_wan1
add chain=prerouting connection-mark=wan2_conn in-interface=bridge1 action=mark-routing new-routing-mark=to_wan2

/ ip route
add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_wan1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_wan2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=pppoe-out1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=pppoe-out2 distance=2 check-gateway=ping

/ ip firewall nat
add chain=srcnat out-interface=pppoe-out1 action=masquerade
add chain=srcnat out-interface=pppoe-out2 action=masquerade
[/quote]

 ขอบคุณครับ
#16 - วันที่ 29 กันยายน 2014, 17:07:44

ถ้าเราต้องการให้ส่งเมล์ออก วิ่งผ่านเฉพาะขา Wan 1 สามารถทำได้ไหมครับ
#17 - วันที่ 10 กุมภาพันธ์ 2015, 17:35:35

70/10
15/1


ใช้ hotspot ร่วมด้วย
แบบ static  ต้องเซตค่าอย่างไรบ้างครับหรือมีสคริปให้เลยก็ดีครับ  ขอบคุณมากครับ
#18 - วันที่ 5 มิถุนายน 2016, 13:59:37

รบกวนหน่อยครับ
ถ้า Internet 2 Link

Wan 1 เป็น bridge mode Speed 100/10
Wan 2 เป็น Route mode speed 20/2

ต้องทำยังไงครับ
#19 - วันที่ 1 กรกฎาคม 2017, 18:45:17


ค่า Internet เท่าไหร่ครับ เดี๋ยวเขียน script ให้ครับ
[/quote]

  เส้น Wan 1 = 50M / 10M
  เส้น Wan 2 = 20M / 2M
[/quote]

ลองดูนะครับ มันคำนวนได้ไม่เป๊ะๆครับ ส่วนขา up ไม่มีผลเท่าไหร่ครับ

/ ip firewall mangle
add chain=input in-interface=pppoe-out1 action=mark-connection new-connection-mark=wan1_conn
add chain=input in-interface=pppoe-out2 action=mark-connection new-connection-mark=wan2_conn

add chain=output connection-mark=wan1_conn action=mark-routing new-routing-mark=to_wan1
add chain=output connection-mark=wan2_conn action=mark-routing new-routing-mark=to_wan2

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no dst-address-type=!local hotspot=auth src-address=192.168.1.0/24 new-connection-mark=\
    wan1_conn passthrough=yes per-connection-classifier=both-addresses:3/0

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no dst-address-type=!local hotspot=auth src-address=192.168.1.0/24 new-connection-mark=\
    wan1_conn passthrough=yes per-connection-classifier=both-addresses:3/1

add action=mark-connection chain=prerouting connection-mark=no-mark disabled=\
    no dst-address-type=!local hotspot=auth src-address=192.168.1.0/24 new-connection-mark=\
    wan2_conn passthrough=yes per-connection-classifier=both-addresses:3/2

add chain=prerouting connection-mark=wan1_conn in-interface=bridge1 action=mark-routing new-routing-mark=to_wan1
add chain=prerouting connection-mark=wan2_conn in-interface=bridge1 action=mark-routing new-routing-mark=to_wan2

/ ip route
add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_wan1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_wan2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=pppoe-out1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=pppoe-out2 distance=2 check-gateway=ping

/ ip firewall nat
add chain=srcnat out-interface=pppoe-out1 action=masquerade
add chain=srcnat out-interface=pppoe-out2 action=masquerade
[/quote]

สอบถามเพิ่ม ถ้าเล้นใดเส้นนึงเป็น มี IP จริงที่ต้องใช้งานในนั้นด้วย จะต้องทำยังไงครับ Internet Fix IP 5 IP
#20 - วันที่ 21 กันยายน 2018, 15:37:28

สมาชิก:

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้


*Share Topic

Share via facebook

*Similar Topics

https://sysnetcenter.com/board/Themes/Nebula_Theme_CR_v1-0-5/images/post/xx.gif
การทำ Loadbalance Internet Static IP 2 เส้น แบบ PCC

เริ่มโดย moowaan เมื่อ อุปกรณ์ Ubiquiti (ยูบิ-คิวตี้)

0 ตอบ
869 อ่าน
กระทู้ล่าสุด: วันที่ 23 มกราคม 2020, 14:54:05
โดย
moowaan
https://sysnetcenter.com/board/Themes/Nebula_Theme_CR_v1-0-5/images/post/xx.gif
การทำ Loadbalance Internet Static IP 2 เส้น มันไม่ต่ออีกเส้นกรณีเน็ตอีกเส้นหลุด

เริ่มโดย pac7584 เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
2252 อ่าน
กระทู้ล่าสุด: วันที่ 12 กันยายน 2014, 20:25:47
โดย
pac7584
https://sysnetcenter.com/board/Themes/Nebula_Theme_CR_v1-0-5/images/post/xx.gif
การทำ Loadbalance Internet ADSL 3 เส้น (PPPoE) แบบ PCC

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

2 ตอบ
6496 อ่าน
กระทู้ล่าสุด: วันที่ 8 พฤศจิกายน 2013, 18:41:37
โดย
pracha
https://sysnetcenter.com/board/Themes/Nebula_Theme_CR_v1-0-5/images/post/xx.gif
QNO QVF7303 VPN LOADBALANCE ROUTER รวม INTERNET 4 เส้น VPN 100TUNNELS รองรับ 300

เริ่มโดย wa_it เมื่อ สอบถามข้อมูลทั่วๆไป ข่าวสารจากร้าน Sysnet Center

2 ตอบ
4268 อ่าน
กระทู้ล่าสุด: วันที่ 13 ตุลาคม 2016, 11:04:45
โดย
Napapon
https://sysnetcenter.com/board/Themes/Nebula_Theme_CR_v1-0-5/images/post/xx.gif
ขอ script LoadBalance 2 เส้น

เริ่มโดย cat8520 เมื่อ อุปกรณ์ Mikrotik Router

3 ตอบ
2813 อ่าน
กระทู้ล่าสุด: วันที่ 21 มีนาคม 2013, 14:55:48
โดย
tOn—