Knowledge Zone:: By Sysnet การ config และ ใช้งานอุปกรณ์ Network

ทดสอบ Block การเข้า Web สำหรับ User ที่ใช้ Ultrasurf ด้วย Mikrotik

Discussion started on อุปกรณ์ Mikrotik Router

ใหม่!

ทดสอบ Block การเข้า Web สำหรับ User ที่ใช้ Ultrasurf ด้วย Mikrotik



ใน Webboard ผมเคยลงวิธีการ Block Website โดยใช้ Function Proxy ของอุปกรณ์ Mikrotik RouterBoard ที่นี้มีลูกค้าท่านนึงซึ่งเป็น Admin ดูแลระบบสอบถามกรณี User ใช้โปรแกรม UltraSurf ในการเข้าใช้งาน Website ที่ Block เอาไว้ได้  ???


ผมลอง Download โปรแกรม Ultrasurf มาใช้ และทดสอบ Block Web ด้วยอุปกรณ์ Mikrotik RouterBoard ของที่ร้าน มันทะลุได้หมดจริงๆครับ  เข้าใจเล่น :P




จากการตรวจสอบใน Sniff Tool ของ Mikrotik พบว่ามีการวิ่งไปที่ IP 65.49.x.x ผ่าน Port SSL (443) ตลอดเลย แสดงว่าตัวโปรแกรมมันน่าจะเข้ารหัสข้อมูล แล้วก็วิ่งไปที่ Server นี้ก่อน แล้วไปยัง Website ต่างๆอีกที




การ Block SSL จะไม่สามารถทำการ Block ได้ครับ เพราะ Packet มันเข้ารหัสไว้

แต่... Block ที่ Server เลย Mikrotik ทำได้สบายๆ ครับ แต่ต้องรู้หมายเลข IP ของ Server ที่เราจะ Block อาจจะต้องใช้ Sniff Tool ในการตรวจสอบว่าเชื่อมต่อ Server อะไรอยู่บ้าง  ซึ่ง IP ที่จะทำการ Block ของ โปรแกรมนี้ จะมีอยู่ 2 ชุดคือ 65.49.0.0 และ 204.107.140.0



ใน Wiki ของ Mikrotik จะมี Script การ Block เอาไว้ครับ ซึ่งการทำงานค่อนข้างโหดอยู่

เพราะจะ Block User ที่ใช้โปรแกรม UltraSurf ไม่ให้ออก Internet ด้วย  :o :o

ถ้าเราตั้ง TimeOut ไว้นานๆ ทาง User ที่เข้า Internet ไม่ได้ ก็จะต้องมาติดต่อเรา จากนั้นก็ค่อยแจ้งว่าห้ามใช้โปรแกรม Ultrasurf ไม่อย่างนั้น ระบบจะรวนหรืออะไรก็ว่ากันไป หุๆๆ  ;D ;D ;D


Script ครับ Copy & Paste ที่ New Terminal ได้เลย

โค๊ด: [Select]
/ip firewall filter
add action=drop chain=forward comment="Block UltraSurf" disabled=no dst-port=\
443 protocol=tcp src-address-list=UltraSurfUsers


/ip firewall mangle
add action=add-src-to-address-list address-list=UltraSurfUsers \
address-list-timeout=50m chain=prerouting comment=UltraSurfUsers disabled=\
no dst-address-list=UltraSurfServers dst-port=443 protocol=tcp


/ip firewall address-list
add address=65.49.0.0/17 comment="" disabled=no list=UltraSurfServers
add address=204.107.140.0/24 comment="" disabled=no list=UltraSurfServers





ตรวจสอบ Script ที่ Run ไว้

ใน NAT ผมสร้าง Transparent Proxy เอาไว้ครับ








Script นี้มันจะ Block IP ที่พยายามเชื่อมต่อไปยัง UltraSurf Server ด้วยครับ ใครที่ Run โปรแกรม จะมีรายการโชว์ใน Address List ชัดเจน





เข้า Web ไม่ได้แล้วครับ รวมถึง Web อื่นๆด้วย  ;D ;D




วิธีแก้เพื่อให้ User เข้า Internet ได้ปกติ ให้ลบ Address ของ User ออกครับ




เมื่อ User ปิดโปรแกรม Ultrasurf ก็จะโดน Block Website ตามปกติที่เราตั้งเอาไว้





เรียบร้อยครับ  ;D ;D
#1 - วันที่ 17 เมษายน 2013, 18:19:48

สมาชิก:

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้


* Share Topic

Share via facebook

* Similar Topics

xx
การสร้าง User ด้วย UserManager สำหรับ RouterOS V5 ขึ้นไป (Update 17/05/2013)

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

44 ตอบ
20504 อ่าน
กระทู้ล่าสุด วันที่ 11 กรกฎาคม 2019, 11:44:00
โดย seefly
xx
การ Block ไม่ให้ User ที่ Fix IP เข้ามาออก Internet ได้ ด้วย Draytek Vigor300B

เริ่มโดย yod เมื่อ อุปกรณ์ DrayTek (เดรเทค)

0 ตอบ
4402 อ่าน
กระทู้ล่าสุด วันที่ 13 กรกฎาคม 2017, 15:23:54
โดย yod
xx
การ Block Youtube ด้วย Mikrotik Routerboard

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

5 ตอบ
26127 อ่าน
กระทู้ล่าสุด วันที่ 4 มิถุนายน 2014, 11:46:59
โดย entity
xx
Mikrotik block การใช้งาน User แบบนี้ได้ไหมครับ

เริ่มโดย birdonline เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
2630 อ่าน
กระทู้ล่าสุด วันที่ 28 เมษายน 2017, 20:10:39
โดย birdonline
xx
Block Bittorrent ด้วย Mikrotik Router Board

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

27 ตอบ
18376 อ่าน
กระทู้ล่าสุด วันที่ 9 กรกฎาคม 2018, 16:29:12
โดย JJJ_2525