การ Config Dynanic DNS บน Mikrotik ในกรณีทำ Load Balance
เพิ่ม Script ใน Menu Winbox System --> Scripts
แก้ไขในส่วน Code ที่เป็นสีแดง ตามนี้ครับ
user-name: dyndns username
password: dyndns password
device-interface: ชื่อ Interface ที่เชื่อมต่อ Internet เช่น pppoe-out1
dyndns-host-name: ชื่อ Host Name ที่สร้างไว้ใน DynDNS.org
:local ddnsuser "user-name"
:local ddnspass "password"
:local theinterface "device-interface"
:local ddnshost "dyndns-host-name"
:local ipddns [:resolve $ddnshost];
:local ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
:if ([ :typeof $ipfresh ] = nil ) do={
:log info ("DynDNS: No ip address on $theinterface .")
} else={
:for i from=( [:len $ipfresh] - 1) to=0 do={
:if ( [:pick $ipfresh $i] = "/") do={
:set ipfresh [:pick $ipfresh 0 $i];
}
}
:if ($ipddns != $ipfresh) do={
:log info ("DynDNS: IP-DynDNS = $ipddns")
:log info ("DynDNS: IP-Fresh = $ipfresh")
:log info "DynDNS: Update IP needed, Sending UPDATE...!"
:local str "/nic/update?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
:delay 1
:local str [/file find name="DynDNS.$ddnshost"];
/file remove $str
:global ipddns $ipfresh
:log info "DynDNS: IP updated to $ipfresh!"
} else={
:log info "DynDNS: dont need changes";
}
}
จะเป็นการส่งค่า IP Address ขา Wan ของ Mikrotik ไปยัง Dynamic DNS Server
Users found this pages searching for: