Welcome to Sysnet Board คู่มือ การใช้งานอุปกรณ์ Network. Please log in or sign up.
สมาชิกทั้งหมด
17,642
กระทู้ทั้งหมด
10,065
หัวข้อทั้งหมด
4,727

  • คู่มือการทำ L3-Based VLAN บนอุปกรณ์ Ruijie XS-1960 Series แบบ GUI
    เริ่มโดย yod
    Read 7,862 times
0 สมาชิก และ 1 ผู้มาเยือน กำลังดูหัวข้อนี้
yod

 

 
คู่มือการทำ L3-Based VLAN บนอุปกรณ์ Ruijie XS-1960 Series แบบ GUI


หัวข้อนี้จะเป็นการทำ Inter VLAN แบบ SVI (Switch Virtual Interface) ครับ


Ruijie XS-1960 Series เหมาะกับการนำไปทำเป็น Core Switch ได้เป็นอย่างดี ในราคาที่ประหยัดกว่า Switch Managed ยี่ห้ออื่นๆ ที่ Spec ใกล้เคียงกัน และ config ง่ายมากครับ

ติดต่อทาง Line @sysnet ได้เลยนะครับ ทางร้านยินดีให้ราคาส่วนลดพิเศษครับ





ตัวอย่างการ Config Ruijie Switch แบบ SVI สามารถนำไปใช้กับ Switch Ruijie ที่รองรับ L2+ , L3 Managed ได้ทุกรุ่นครับ


Ruijie XS-1960 เป็น DHCP Server รวมถึงตัวอย่างในการใช้ ACL สำหรับ Block Traffic ระหว่าง VLAN 30 และ VLAN 40

VLAN 1: Port G1 เชื่อมต่อกับ Router IP: 192.168.3.243/24
VLAN 10: Port G3-G4 สำหรับ Server วง Network 10.0.10.0/24
VLAN 20: Port G5-G6 สำหรับ CCTV วง Network 10.0.20.0/24
VLAN 30: Port G7-G8 สำหรับ Account วง Network 10.0.30.0/24
VLAN 40: Port G9-G10 สำหรับ Sale วง Network 10.0.40.0/24
G24 Trunk Port ให้ VLAN 10,20,30 และ 40 ไปยัง Switch ตัวที่ 2

ต่อ Switch เข้ากับ Gateway (Mikrotik) ในตัวอย่างต่อผ่าน Port G1 และ ต่อ PC เข้ากับ Port G2


IP Default ของ Switch จะเป็น DHCP Client แต่ถ้าไม่ได้ต่อเข้า DHCP Server จะเป็น IP 192.168.110.1 user/password: admin/admin


Login เข้า Ruijie Switch ผ่าน Browser





1. แก้ไข IP VLAN 1 ของ Ruijie Switch

Menu VLAN







2. สร้าง VLAN 10, 20, 30 และ 40

VLAN: 10
VLAN Name: Server
IPv4: Manaul Configuration
IPv4: 10.0.10.1/255.255.255.0

Click เลือก Port ที่ต้องการให้เป็นสมาชิก VLAN ที่สร้างได้เลยครับ โดย Default แต่ละ Port จะเป็น Access Port อยู่แล้ว






ตัวอย่าง VLAN 20






สร้าง VLAN 30 และ 40






ตรวจสอบผ่าน cli จะใช้ command เหมือน cisco ครับ







กำหนด Port G24 เป็น Port Trunk





Link Type: Trunk






3. สร้าง DHCP Server

Menu More --> DHCP Server





Enable DHCP Server

กำหนด Excluded Address Range เป็นการบอกให้ DHCP Server ไม่แจก IP Address ในช่วงที่กำหนด





Address Pool List --> Click [Add] เพื่อสร้าง DHCP IP Pool

Name: pool_server
IP: 10.0.10.1
Mask: 255.255.255.0
Default Gateway: 10.10.10.1
DNS: 8.8.8.8






ตัวอย่าง VLAN 20: pool_cctv






สร้างทุกๆ Pool แต่ถ้าวง Network ไหน ไม่ได้แจก IP ก็ไม่ต้องสร้างครับ





ทดสอบ เชื่อมต่อ PC เข้ากับ Port G7 จะต้องได้ IP Address 10.0.30.x แต่จะไม่สามารถออก Internet ได้ครับ ต้องทำ Default Route ก่อน


4. ทำ Default Route

Menu More --> Routing --> Click [Add Default Route]

IP Type: IPv4
Next Hop Address: 192.168.3.1 (IP Gateway)
Routing: Primary Route




ทำ Static Route ที่ Gateway (Mikrotik)




สร้าง Route ให้ครบทุก Network




ทดสอบ

PC ได้ IP: 10.0.30.21 (VLAN 30)




Ping ออก Internet ได้ปกติ




และ Ping ไปยัง VLAN อื่นๆได้ เพราะเป็น Connected Route ครับ




ถ้ามี Tools ช่วยตรวจสอบก็ง่ายดีครับ







5. ถ้าต้อง Block ไม่ให้ระหว่าง VLAN เชื่อมต่อหากันได้ ต้องใช้ Feature ACL ครับ

ตัวอย่าง Block ไม่ให้ VLAN 30 และ VLAN 40 เชื่อมต่อหากันได้ แต่ยังออก Internet ได้ปกติ

Menu More --> ACL & QOS --> Tab ACL




ACL Type: Extended ACL
ACL ID: 100 (ได้ตั้งแต่ 100 - 199)






Rule List --> Click [Add]






Rule 1
ACL Control: Deny
Protocol: IP
Source IP Filter: Any IP
Destination IP FIlter: Wildcard 10.0.30.0/0.0.0.255




Rule 2
ACL Control: Permit
Protocol: IP
Source IP Filter: Any IP
Destination IP FIlter: Any IP




เป็นการ Block ไม่ให้ Traffic วิ่งไปที่วง 10.0.30.0 ที่เหลือวิ่งออกได้หมด






หลังจากสร้าง ACL แล้ว ต่อไปจะเป็นการกำหนดว่าจะนำกฏไปใช้ที่ Port หรือ VLAN ไหน

Menu Port Policy --> Click [Add]





Policy: ACL 100
Direction: Input
VLAN Interface: VLAN 40








ทดสอบ Ping จาก VLAN 40 มา VLAN 30 จะไม่สามารถ Ping ได้ แต่ออก Internet ได้ปกติ และ เชื่อมต่อกับ Network อื่นๆได้





เรียบร้อยครับ 8)


CLI ครับ

ถ้าบนอุปกรณ์ Switch ผมถนัด Command Line มากกว่าครับ เพราะไม่มี menu มาให้งง บาง feature หา menu ไม่เจออีก อย่างหัวข้อนี้ผมก็ทำผ่าน command line ก่อนครับ แล้วดูใน gui ว่ามันเป็นค่าอะไร ;D

!
no spanning-tree
!
ip access-list extended 100
10 deny ip any 10.0.30.0 0.0.0.255
20 permit ip any any
!
service dhcp
ip dhcp excluded-address 10.0.10.1 10.0.10.20
ip dhcp excluded-address 10.0.20.1 10.0.20.20
ip dhcp excluded-address 10.0.30.1 10.0.30.20
ip dhcp excluded-address 10.0.40.1 10.0.40.20
!
ip dhcp pool pool_server
lease 0 8 0
network 10.0.10.0 255.255.255.0
dns-server 8.8.8.8
default-router 10.0.10.1
!
ip dhcp pool pool_cctv
network 10.0.20.0 255.255.255.0
dns-server 8.8.8.8
default-router 10.0.20.1
!
ip dhcp pool pool_account
lease 0 8 0
network 10.0.30.0 255.255.255.0
dns-server 8.8.8.8
default-router 10.0.30.1
!
ip dhcp pool pool_sale
lease 0 8 0
network 10.0.40.0 255.255.255.0
dns-server 8.8.8.8
default-router 10.0.40.1
!
install 0 XS-S1960-24GT4SFP-H
!
sysmac 8005.88ec.df70
ip name-server 8.8.8.8
!
enable service web-server http
enable service web-server https
!       
nfpp
!
no service password-encryption
!
redundancy
!
clock timezone UTC +7 0
!
no zam
!
vlan 10
name Server
!
vlan 20
name CCTV
!
vlan 30
name Account
!
vlan 40
name Sale
!
vlan 1
!       
interface GigabitEthernet 0/1
!
interface GigabitEthernet 0/2
!
interface GigabitEthernet 0/3
switchport access vlan 10
!
interface GigabitEthernet 0/4
switchport access vlan 10
!
interface GigabitEthernet 0/5
switchport access vlan 20
!
interface GigabitEthernet 0/6
switchport access vlan 20
!
interface GigabitEthernet 0/7
switchport access vlan 30
!
interface GigabitEthernet 0/8
switchport access vlan 30
!
interface GigabitEthernet 0/9
switchport access vlan 40
!
interface GigabitEthernet 0/10
switchport access vlan 40
!
interface GigabitEthernet 0/11
!
interface GigabitEthernet 0/12
!
interface GigabitEthernet 0/13
!
interface GigabitEthernet 0/14
!
interface GigabitEthernet 0/15
!
interface GigabitEthernet 0/16
!
interface GigabitEthernet 0/17
!
interface GigabitEthernet 0/18
!
interface GigabitEthernet 0/19
!
interface GigabitEthernet 0/20
!       
interface GigabitEthernet 0/21
!
interface GigabitEthernet 0/22
!
interface GigabitEthernet 0/23
!
interface GigabitEthernet 0/24
switchport mode trunk
!
interface GigabitEthernet 0/25
!
interface GigabitEthernet 0/26
!
interface GigabitEthernet 0/27
!
interface GigabitEthernet 0/28
!
interface VLAN 1
ip address 192.168.3.243 255.255.255.0
!
interface VLAN 10
ip address 10.0.10.1 255.255.255.0
!
interface VLAN 20
ip address 10.0.20.1 255.255.255.0
!
interface VLAN 30
ip address 10.0.30.1 255.255.255.0
!
interface VLAN 40
ip access-group 100 in
ip address 10.0.40.1 255.255.255.0
!
ntp server time.google.com
ntp server 0.pool.ntp.org
ntp server 1.pool.ntp.org
!
ip route 0.0.0.0 0.0.0.0 192.168.3.1
!
line console 0
line vty 0 4
login
!
end