Welcome to Sysnet Board คู่มือ การใช้งานอุปกรณ์ Network. Please log in or sign up.
สมาชิกทั้งหมด
17,647
กระทู้ทั้งหมด
10,068
หัวข้อทั้งหมด
4,727

  • การ Update เวลา Mikrotik Router ตามเวลามาตรฐานสากล (NTP Time)
    เริ่มโดย yod
    Read 50,946 times
0 สมาชิก และ 1 ผู้มาเยือน กำลังดูหัวข้อนี้
yod

 

 

การ Update เวลา อุปกรณ์ Mikrotik RouterBoard ตามเวลามาตรฐานสากล



ตัว RouterBoard จะไม่มีพวก Battery ที่เก็บค่าต่างๆเหมือน Bios ของ Computer ครับ เพราะฉะนั้นเวลาปิดเปิดเครื่อง เวลา มันจะกลับไปเป็น 00:00 ต้องมีการตั้งค่าโดยไปนำเวลามาจาก NTP Server ต่างๆครับ


โดย Default Package ของ RouterBoard จะไม่มี NTP  ต้องติดตั้ง Package NTP ก่อน

หลังจากติดตั้งเรียบร้อยแล้ว Copy Code ด้านล่างลง New Terminal ได้เลย แต่ต้องต่อให้ RouterBoard ออก Internet ให้ได้ก่อนนะครับ


/system clock
set time-zone-name=Asia/Bangkok

/system ntp client
set enabled=yes mode=unicast primary-ntp=202.28.18.72 secondary-ntp=0.0.0.0



Primary-NTP จะมีหลายที่นะครับ
158.108.212.149
203.158.118.2

ntp.ku.ac.th
th.pool.ntp.org
pool.ntp.org


จากนั้นก็ตรวจสอบเวลาที่ Menu System --> Clock



#3
 ท่านสามารถ copy คำสั่งนี้ และไป paste ที่ new terminal ได้ทันทีครับ
/system ntp client set enabled=yes mode=unicast primary-ntp=158.108.212.149 secondary-ntp=202.28.18.72
/system clock set time-zone-name=Asia/Bangkok
ต้องขึ้น

ถ้าขึ้นแบบนี้แสดงยังไม่ทำงาน

ให้ใช้ตัวนี้ดูครับ
#set ntp
/system ntp client
set enabled=yes mode=unicast primary-ntp=203.185.69.ุ60 secondary-ntp=203.185.69.59
/system clock
set time-zone-name=Asia/Bangkok

ผมใช้วิธีในกระทู้ด้านล่างเซ็ต NTP แทน ไม่ทราบใช้แทนกันได้ไหมครับ พอดีวิธีที่กระทู้นี้แนะนำ มันขึ้น bad command ใน new terminal น่ะครับ stem อะไรซักอย่างเนี่ยแหละ 555+

https://www.sysnetcenter.com/board/index.php/topic,423.0.html

ขอสอบถามหน่อยครับ

คุณยอดครับ Mikrotik 450 ไม่อัพเดทเวลาให้นะครับ ทั้งๆ ที่ NTP  ก็ใช้ได้ปกติ จะเกี่ยวกับที่ผม shotdow mikrotik ทุกวันหรื่อเปล่าครับ เพราะเป็นมาหลายครั้งแล้วครับ เปิดเครื่องมาแล้วเวลาไม่อัพเดทตาม พอมีวิธีแก้ไหมครับ ตอนนี้ scirpt ไม่อัพเดทเลยครับ ไม่ยอมรันเลย
  เน็ตก็ออกได้ปกติครับ พอเข้าไปเปลี่ยน NTP ตามสลิปที่ ก็ใช้ได้ประมาณวันถึงสองวันก็เป็นอีกครับ

yod


ไม่ควร shutdown หรือ reboot บ่อยๆ ครับ เพราะ ntp client พอใส่ไป ตัว mikrotik มัน resolve เป็นหมายเลข ip และถ้าช่วงนั้น ip เขาเปลี่ยน เวลาจะไม่ update ครับ