Welcome to Sysnet Board คู่มือ การใช้งานอุปกรณ์ Network. Please log in or sign up.
สมาชิกทั้งหมด
17,637
กระทู้ทั้งหมด
10,062
หัวข้อทั้งหมด
4,727

  • การใช้ Mikrotik ทำ Hotspot โดยต่อ AP ผ่าน Switch
    เริ่มโดย Mr.Zenith
    Read 13,538 times
0 สมาชิก และ 1 ผู้มาเยือน กำลังดูหัวข้อนี้

 

 
สวัสดีครับ

ตอนนี้ใช้ RB450G อยู่ ซึ่งทางผมมี AP ประมาณ 6-7 ตัว จึงไม่สามารถต่อไปบน Mikrotik ได้ทั้งหมด ต้องการสอบถามว่า ผมมี Switch Cisco รุ่น SF200-24 เป็น Layer 2 แบบ Manage ได้ จะต้องคอนฟิก Mikrotik , Switch อย่างไรครับ หากจะนำ AP ไปต่อบน Switch แทนที่จะต่อบน Mikrotik โดยตรง และอยากแบ่ง VLAN บน Switch ด้วยน่ะครับ เพื่อให้ Client ไม่สามารถติดต่อกันได้ และแจก DHCP IP สำหรับใช้บริการ Hotspot สำหรับแต่ละ AP ต่างกันออกไป

Mikrotik ----> Switch ----> AP1 (VLAN100 : 192.168.1.100 - 192.168.1.200)
                               ----> AP2 (VLAN101 : 192.168.2.100 - 192.168.2.200)
                               ----> AP3 (VLAN102 : 192.168.3.100 - 192.168.3.200)

ไม่ทราบว่าทางคุณยอดพอจะมีคำแนะนำการเซ็ตเป็นตัวอย่างให้ดูสัก 1 VLAN 1 AP ไหมครับ เห็นทางร้านมี Switch รุ่นนี้จำหน่ายอยู่พอดีเช่นกัน

หากเพื่อนสมาชิกท่านใดเคยทำ ลองแชร์ความเห็นมาได้นะครับ

ขอบคุณครับ

#1
เอาให้ดูเป็นตัวอย่างครับ
สร้าง Bridge ขึ้นมาก่อน เสร็จแล้วสร้าง hotspot บน bridge ที่สร้างขึ้นจะสร้างกี่ bridge ก็ได้ความความต้องการ ตามสคริปสร้างไว้ 2 วงคือ intranet กับ hotspot จากนั้นก็สร้าง vlan บน interface ที่ต้องการ แล้วก็ทำการ bridge port เข้ากับ vlan ตามสคริป

/interface bridge
add l2mtu=1594 name=Intranet
add l2mtu=1594 name=Hotspot

/interface vlan
add interface=ether4 l2mtu=1594 name=vlan100 vlan-id=100
add interface=ether4 l2mtu=1594 name=vlan101 vlan-id=101
add interface=ether4 l2mtu=1594 name=vlan102 vlan-id=102
add interface=ether4 l2mtu=1594 name=vlan103 vlan-id=103
add interface=ether4 l2mtu=1594 name=vlan104 vlan-id=104

/interface bridge port
add bridge=Intranet interface=vlan100
add bridge=Hotspot interface=vlan101
add bridge=Hotspot interface=vlan102
add bridge=Hotspot interface=vlan103
add bridge=Hotspot interface=vlan104

ส่วนสวิทช์พอร์ตที่ต่อกับ mikrotik เซ็ทเป็น trunk พอร์ทที่ต่อเข้ากับ AP เซ็ทเป็น mode access หรือ general ก็ได้ แต่ถ้า AP ที่รองรับ vlan ก็อาจเซ็ตเป็น trunk ที่พอร์ตสวิทช์ก็ได้ครับเพื่อแยก ssid กับ manage



yod

ขอบคุณมากครับ เดี๋ยวขอนำไปทดลองดูก่อนนะครับ หากติดขัดประการใดจะสอบถามเพิ่มเติมครับผม

ทดลองทำตามด้านบนแล้วนะครับ แต่ยังพบปัญหาอยู่หน่อยครับ

ขณะนี้ Switch พอร์ตที่ 24 ต่อเข้ากับ Mikrotik พอร์ตที่ 2 ครับ
AP ตัวแรกต่อเข้ากับ Switch พอร์ตที่ 1

Mikrotik = 192.168.99.1
AP = 192.168.99.12
Switch = 192.168.99.3

การเซ็ตที่ Switch
Port 24 เป็น Trunk Mode
Port 1 เป็น General Mode ตั้งเป็น Untagged ที่พอร์ต 1 แล้วตั้งเป็น Tagged ที่พอร์ต 24

การเซ็ตที่ Mikrotik

อ้างถึง/interface bridge
add l2mtu=1594 name=hotspot

/interface vlan
add interface=ether2 l2mtu=1594 name=vlan102 vlan-id=102

/interface bridge port
add bridge=hotspot interface=vlan102

และสร้าง Hotspot บน Bridge hotspot

ปัญหาที่พบขณะนี้คือใช้ Notebook เชื่อมต่อเข้า Wireless AP แต่กลับสามารถเข้าใช้งานอินเตอร์เน็ตได้เลย ดูกราฟทราฟฟิกพบว่า Traffic วิ่งผ่าน Ethernet 2 แทนที่จะเป็น Bridge ของ vlan ที่ทำไว้ครับ คิดว่าปัญหาน่าจะเกิดจากตรงนี้ว่า Traffic ไปวิ่งผ่าน Ether2 แทนที่จะเป็น vlan ครับ

ลองดูว่าได้ทำ network ไว้บน ether2 โดยตรงหรือไม่ ทางที่ดีที่ switch port1 ควรเซ็ตเป็น access mode ถ้าเซ็ตเป็น general mode ควรจะมีอย่างน้อย 2 vlan untagged vlan ควรจะเป็น manage vlan

yod

ข่วงนี้ติดควบคุมงานก่อสร้าง ครับ ต้องเดินทางบ่อยเลยไม่ค่อยได้เข้ามา ช่วงต้นเดือนต้องลงไปรับลูกชายที่กรุงเทพ เรียนจบแล้ว อาจจะแแวะไปเยี่ยมที่ร้านนะครับ

yod


ลูกชายพี่คนที่เคยมาเอาของที่ร้านป่าวครับ เรียนจบแล้วเหรอครับพี่ ยินดีด้วยนะครับ  ;D ;D ;D



ของผมคนโตเพิ่ง 3 ขวบ อีกนานเลย  ::) ::)