Welcome to Sysnet Board คู่มือ การใช้งานอุปกรณ์ Network. Please log in or sign up.
สมาชิกทั้งหมด
17,653
กระทู้ทั้งหมด
10,069
หัวข้อทั้งหมด
4,727

  • เอา Code ให้ mikrotik ส่ง log เข้า E-Mail มาฝากครับ
    เริ่มโดย ksr312
    Read 7,381 times
0 สมาชิก และ 1 ผู้มาเยือน กำลังดูหัวข้อนี้

 

 
เอา Code ให้ mikrotik ส่ง log เข้า E-Mail มาฝากครับ
เนื่องจาก Mikrotik เก็บ Log ได้แค่ 100Log ผมก็เลยตั้งเวลาส่งเข้าเก็บที่ Email แทน
และโค้ดนี้ยังขยายให้ Mikrotik เกิด Log ได้เพิ่มขึ้นน่าจะเป็น 65000Log(ถ้าไม่เข้าใจผิดนะ) จากเดิมแค่100Log หรือจนกว่า Mem จะเต็ม
เผื่อเป็นประโยชน์ครับ

#=============================================================
#read log
:local logcontent
:foreach int in=[/log find ] do={
:set logcontent ("$logcontent
" .[/log get $int time]. " - " .[/log get $int message])
}

#send email
/tool e-mail send to="ใส่ชื่ออีเมลล์ที่จะส่งเข้า" password=ใส่รหัสผ่านGmail  subject=([/system identity get name] . " Log " . [/system clock get date]) body=$logcontent  from=ใส่ชื่ออีเมลล์ของGmail   server=173.194.69.109 tls=yes

#delete old log
/system logging action set memory memory-lines=1
/system logging action set memory memory-lines=65000
#===================================================================


ขออนุญาตคัดลอกข้อความคุณยอด
สมัคร gmail account ให้เรียบร้อยก่อนครับ
เข้า Winbox --> Tool --> Email

Server: 173.194.69.109 (เป็น Mail Server ของ gMail)
Port: 587
From: ชื่อ gmail ที่สมัครไว้
User: ชื่อ gmail ที่สมัครไว้
Password: : password ของ gmail ที่สมัครไว้



Click [OK]

แล้วก็ไป กำหนด scheduler กำหนดเวลาในการส่ง (อย่าตั้งเวลาส่งบ่อย รู้สึก เขาจะให้ส่งวันละไม่เกิน 100 ข้อความ มากว่านั้นจะถูก Block)
ตั้งส่งวันละ 1ครั้งกำลังดีครับ
ผมลองส่งแล้ว ตั้งเวลาส่งทุก 3นาที ส่งไปได้ไม่น่าเกิน50ครั้ง ก็ถูกบล็อกแล้ว Gmail ขึ้น"คุณได้ส่งจดหมายถึงขีดจำกัดที่กำหนดไว้แล้ว"
ใครมีวิธีให้ส่งได้มากกว่านี้ ช่วยบอกด้วยนะครับ

yod