Welcome to Sysnet Board คู่มือ การใช้งานอุปกรณ์ Network. Please log in or sign up.
สมาชิกทั้งหมด
17,670
กระทู้ทั้งหมด
9,931
หัวข้อทั้งหมด
4,628

  • การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube
    เริ่มโดย yod
    Read 36,562 times
0 สมาชิก และ 1 ผู้มาเยือน กำลังดูหัวข้อนี้
yod

 

 

การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube


มีลูกค้าสอบถามเข้ามาครับ ต้องการกำหนดช่วงเวลาการใช้งาน Youtube แต่จะ Block ไม่ให้ใช้เลยก็ดูไม่ดี เลยจะใช้เป็นการบีบความเร็วลงจะดีกว่า


1. Login เข้า Winbox

เข้า Menu IP --> Firewall --> Layer7 Protocols

สร้าง L7 Expression ของ Youtube
Name: youtube
Regexp: ^.+(youtube).*$



Click [OK]

หรือ Run scrip ตามนี้

/ip firewall layer7-protocol add comment="" name=youtube regexp="Regexp: ^.+(youtube).*$"


2. สร้าง Mangle เพื่อจับ Packet youtube

IP --> Firewall --> Mangle

Tab General
Chain: prerouting



Tab Advanced
Layer7 Protocol: youtube



Tab Action
Action: mark packet
New Packet Mark: mp-youtube



ใส่ Comment เป็น mp-youtube



Click [OK]

/ip firewall mangle
add action=mark-packet chain=prerouting \
comment="mp-youtube" disabled=no \
layer7-protocol=youtube new-packet-mark=mp-youtube \
passthrough=no


ทดสอบเปิด Youtube จะต้องมี Packet วิ่ง




3. กำหนด Queue
Menu Queue --> Queue Tree
Tab General

Name: q-youtube
Parent: global
Packet Marks: mp-youtube
Queue Type: default
Max Limit: 128k (ปรับเปลี่ยนตามต้องการครับ)



Click [OK]

ทดสอบเปิด Youtube จะต้องมี Packet วิ่ง และ Status เป็นสีแดง แสดงว่า Queue ทำงานแล้วครับ




4. ทีนี้จะเป็นการสร้าง Script เพื่อ Enable/Disable ครับ ซึ่งผมได้อธิบายไว้อย่างละเอียดในหัวข้อนี้ครับ (สำหรับสมาชิก Mikrotik Groupt นะครับ)การเขียน Script Schedule Enable/Disable ในอุปกรณ์ Mikrotik

สร้าง Script สำหรับการ Enable
Name: enable-mp-youtube
Source: /ip firewall mangel enable [find comment=mp-youtube]



Click [OK]

สร้าง Script สำหรับการ Disable
Name: disable-mp-youtube
Source: /ip firewall mangel disable [find comment=mp-youtube]



Click [OK]

ลองทดสอบ Run Script ดูด้วยนะครับ




5. ทีนี้จะเป็นการสร้าง Schedule ตัวอย่างจะเป็นการกำหนด Bandwidthช่วงเวลา 8.00-12.00 และ 13.00-17.00 ตรวจสอบเวลาของตัว Mikrotik ให้เรียบร้อยด้วยนะครับ System --> Clock

Copy Script เลยง่ายกว่า

system scheduler add name=sch-enable-mpyoutube start-date=nov/06/2012 start-time=08:00:00 interval=1d on-event=enable-mp-youtube policy=read,write
system scheduler add name=sch-disable-mpyoutube start-date=nov/06/2012 start-time=12:00:00 interval=1d on-event=disable-mp-youtube policy=read,write

system scheduler add name=sch-enable-mpyoutube2 start-date=nov/06/2012 start-time=13:00:00 interval=1d on-event=enable-mp-youtube policy=read,write
system scheduler add name=sch-disable-mpyoutube2 start-date=nov/06/2012 start-time=17:00:00 interval=1d on-event=disable-mp-youtube policy=read,write






จะได้ตามนี้ครับ





เรียบร้อย  ;D ;D


ผมลองเซ็ตตามที่แนะนำแล้ว แต่ผมไม่ได้ตั้งเวลาว่าจะจำกัดเวลาไหนบ้าง คือผมอยากให้จำกัดตลอดเลย แต่ปรากฏว่าเข้าเว็บ youtube ไม่ได้เลย แต่พอลบค่าที่เซ็ตไว้ทั้งหมดออกเข้าได้ ไม่ทราบว่าผมต้องแก้ไขยังไงครับ


#3
ได้แล้วครับ ขอบคุณมากครับ

สอบถามเพิ่มครับ
ถ้าจะให้ disable ช่วง เสาร์-อาทิตย์ด้วยต้องไปแก้ไขยังไงครับ

ผมทำให้มัน diable เสาร์อาทิตย์ได้แล้วครับ
แต่อยากรู้ว่าถ้าจะยกเลิกการจำกัดเป็นราย user จะทำยังไงครับ

การเขียน Script Schedule Enable/Disable ในอุปกรณ์ Mikrotik เปิดไม่ได้หรือไม่มีแล้วครับ