Welcome to Sysnet Board คู่มือ การใช้งานอุปกรณ์ Network. Please log in or sign up.
สมาชิกทั้งหมด
17,637
กระทู้ทั้งหมด
10,062
หัวข้อทั้งหมด
4,727

  • รวบรวม Script สำหรับ Mikrotik RouterBoard ที่จำเป็นต่อการใช้งาน
    เริ่มโดย yod
    Read 40,694 times
0 สมาชิก และ 1 ผู้มาเยือน กำลังดูหัวข้อนี้
yod

 

 

รวบรวม Script สำหรับ RouterBoard ที่จำเป็นต่อการใช้งาน



เป็น Script ที่รวบรวมมา ปรับแต่งบ้าง ทดลองกับ RouterOS 4.11 ทำงานได้อย่างสมบูรณ์ครับ

ควรจะมีไว้นะครับ เพื่อช่วยให้ตัว Router Board ทำงานได้มีประสิทธิภาพยิ่งขึ้น โดยผมจะทยอยๆ Up ขึ้น Webboard หัวข้อนี้เรื่อยๆนะครับ


วิธีติดตั้ง Script

1. Login เข้า Winbox --> System --> Scripts

2. Click [ + ] เพื่อสร้าง New Script



ตั้งชื่อ Script ที่ ช่อง Name
จากนั้น Copy Script ที่ต้องการลงในช่อง Source
เสร็จแล้ว Click [OK]


3. เวลาต้องการ Run Script ก็เลือก Script ที่ Script List แล้ว Click [Run Script]





วิธีติดตั้ง Scheudler เพื่อตั้งเวลาการ Run Script

1. แก้ไข Code ด้านล่างครับ

/system scheduler add name=ClearUserSession interval=60:00:00 on-event="/system script run clear_user_session\r\n"

โดยที่
name=ชื่อ ของ Scheudler
interval=กำหนดเวลาในการ Run จากตัวอย่างจะเป็นทุกๆ 60 ชั่วโมง
run=ชื่อ Script ที่ต้องการ Run (อักษรตัวใหญ่ เล็ก มีผลนะครับ)



จากนั้นเคาะ Enter


2. สามารถแก้ไขเพิ่มเติมได้ที่ Menu System --> Scheudler






Script ต่างๆที่น่าจะติดตั้งไว้ครับ


[Remove UserMan Session]
ลบ Session ใน UserManager เพราะถ้าปล่อยทิ้งไว้นานๆจะทำให้ Memory ใน RouterBoard เต็มครับ ควรตั้งเวลาทุกๆ 200 ชั่วโมง

#Remove all session log in usermanager
:global i
:foreach i in=[/tool user-manager session find] do { /tool user-manager session remove $i; }


******************************************************************************

[Remove UserMan Log]
ลบ Log ใน UserManager เพราะถ้าปล่อยทิ้งไว้นานๆจะทำให้ Memory ใน RouterBoard เต็มครับ และ Rebuild Database ให้ด้วยครับ ควรตั้งเวลาทุกๆ 200 ชั่วโมง

#Remove all log in usermanager
:global i
:foreach i in=[/tool user-manager log find] do { /tool user-manager log remove $i; }
#Rebuild Database
/tool user-manager database rebuild


******************************************************************************

[Reboot RouterBoard เมื่อ System Memory < 5%]

#:global datum [/system clock get date];
:global time [/system clock get time];
:local percentfree ((100 * [/system resource get free-memory]) / [/system resource get total-memory])

/system resource
:if ($percentfree < 5) do={
/system reboot;
};


******************************************************************************

คุณยอด อยากได้ที่มันใช้บน OS 5.12 ได้ด้วยครับ เดี๋ยววันนี้จะลองลงบน  OS 5.12 ครับ

[Remove UserMan Session]
ลบ Session ใน UserManager เพราะถ้าปล่อยทิ้งไว้นานๆจะทำให้ Memory ใน RouterBoard เต็มครับ ควรตั้งเวลาทุกๆ 200 ชั่วโมง

โค๊ด:
#Remove all session log in usermanager
:global i
:foreach i in=[/tool user-manager session find] do { /tool user-manager session remove $i; }

******************************************************************************

[Remove UserMan Log]
ลบ Log ใน UserManager เพราะถ้าปล่อยทิ้งไว้นานๆจะทำให้ Memory ใน RouterBoard เต็มครับ และ Rebuild Database ให้ด้วยครับ ควรตั้งเวลาทุกๆ 200 ชั่วโมง

โค๊ด:
#Remove all log in usermanager
:global i
:foreach i in=[/tool user-manager log find] do { /tool user-manager log remove $i; }
#Rebuild Database
/tool user-manager database rebuild



ถามนิส ครับ คุณ ยอด ตั้ง เวลา ตรงไหน ครับ ผม  ??? ???